using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(?:<div class=""foo"">.*?</div>|$)";
string input = @"<div class=""foo"">.*?</div>dfgdfg
sdfsdfsdfsd<div class=""foo"">.*?</div><div class=""foo"">.*?</div>saasdasdasd
dfehrgerfsda<div class=""foo"">.*?</div>dsfdsfsdfdsf
<div class=""foo"">.*?</div>dfggdd";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}