// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?si)(.*?)(?:<div class="foo">.*?</div>|$)"#).unwrap();
let string = "<div class=\"foo\">.*?</div>dfgdfg
sdfsdfsdfsd<div class=\"foo\">.*?</div><div class=\"foo\">.*?</div>saasdasdasd
dfehrgerfsda<div class=\"foo\">.*?</div>dsfdsfsdfdsf
<div class=\"foo\">.*?</div>dfggdd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}