import Foundation
let pattern = #"(.*?)(?:<div class="foo">.*?</div>|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<div class="foo">.*?</div>dfgdfg
sdfsdfsdfsd<div class="foo">.*?</div><div class="foo">.*?</div>saasdasdasd
dfehrgerfsda<div class="foo">.*?</div>dsfdsfsdfdsf
<div class="foo">.*?</div>dfggdd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)