re = /(.*?)(?:<div class="foo">.*?<\/div>|$)/i
str = '<div class="foo">.*?</div>dfgdfg
sdfsdfsdfsd<div class="foo">.*?</div><div class="foo">.*?</div>saasdasdasd
dfehrgerfsda<div class="foo">.*?</div>dsfdsfsdfdsf
<div class="foo">.*?</div>dfggdd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end