# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<h3 class="lined-header">Dagens meny<\\/h3><h4>(.*?)<\\/h4><p> ?(.*?)<\\/p><h4>(.*?)<\\/h4><p> ?(.*?)<\\/p><a class="link-button" href="\\\[\[https:\\/\\/www\.\\\]\(https:\\/\\/www.fontanhuset.se\\/veckan\)website\.com\\/weeklymenu">Veckans\]\(https:\\/\\/www\.\]\(https:\\/\\/www\.fontanhuset\.se\\/veckan\)website\.com\\/weeklymenu">Veckans\) meny<\\/a>/$1: $2$3: $4/gm;t' <<< "<h3 class=\"lined-header\">Dagens meny</h3><h4>Lunch</h4><p> Rotmos elr potatismos med korv</p><h4>Veg</h4><p> Rotmos elr potatismos med vegkorv</p><a class=\"link-button\" href=\"\[[https://www.\](https://www.fontanhuset.se/veckan)website.com/weeklymenu\">Veckans](https://www.](https://www.fontanhuset.se/veckan)website.com/weeklymenu\">Veckans) meny</a>"