using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h3 class=""lined-header"">Dagens meny<\/h3><h4>(.*?)<\/h4><p> ?(.*?)<\/p><h4>(.*?)<\/h4><p> ?(.*?)<\/p><a class=""link-button"" href=""\\\[\[https:\/\/www\.\\\]\(https:\/\/www.fontanhuset.se\/veckan\)website\.com\/weeklymenu"">Veckans\]\(https:\/\/www\.\]\(https:\/\/www\.fontanhuset\.se\/veckan\)website\.com\/weeklymenu"">Veckans\) meny<\/a>";
string substitution = @"$1: $2$3: $4";
string input = @"<h3 class=""lined-header"">Dagens meny</h3><h4>Lunch</h4><p> Rotmos elr potatismos med korv</p><h4>Veg</h4><p> Rotmos elr potatismos med vegkorv</p><a class=""link-button"" href=""\[[https://www.\](https://www.fontanhuset.se/veckan)website.com/weeklymenu"">Veckans](https://www.](https://www.fontanhuset.se/veckan)website.com/weeklymenu"">Veckans) meny</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}