import Foundation
let pattern = #"<h3 class="lined-header">Dagens meny<\/h3><h4>(.*?)<\/h4><p> ?(.*?)<\/p><h4>(.*?)<\/h4><p> ?(.*?)<\/p><a class="link-button" href="\\\[\[https:\/\/www\.\\\]\(https:\/\/www.fontanhuset.se\/veckan\)website\.com\/weeklymenu">Veckans\]\(https:\/\/www\.\]\(https:\/\/www\.fontanhuset\.se\/veckan\)website\.com\/weeklymenu">Veckans\) meny<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<h3 class="lined-header">Dagens meny</h3><h4>Lunch</h4><p> Rotmos elr potatismos med korv</p><h4>Veg</h4><p> Rotmos elr potatismos med vegkorv</p><a class="link-button" href="\[[https://www.\](https://www.fontanhuset.se/veckan)website.com/weeklymenu">Veckans](https://www.](https://www.fontanhuset.se/veckan)website.com/weeklymenu">Veckans) meny</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1: $2$3: $4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)