# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h3 class=\"lined-header\">Dagens meny<\/h3><h4>(.*?)<\/h4><p> ?(.*?)<\/p><h4>(.*?)<\/h4><p> ?(.*?)<\/p><a class=\"link-button\" href=\"\\\[\[https:\/\/www\.\\\]\(https:\/\/www.fontanhuset.se\/veckan\)website\.com\/weeklymenu\">Veckans\]\(https:\/\/www\.\]\(https:\/\/www\.fontanhuset\.se\/veckan\)website\.com\/weeklymenu\">Veckans\) meny<\/a>"
test_str = "<h3 class=\"lined-header\">Dagens meny</h3><h4>Lunch</h4><p> Rotmos elr potatismos med korv</p><h4>Veg</h4><p> Rotmos elr potatismos med vegkorv</p><a class=\"link-button\" href=\"\\[[https://www.\\](https://www.fontanhuset.se/veckan)website.com/weeklymenu\">Veckans](https://www.](https://www.fontanhuset.se/veckan)website.com/weeklymenu\">Veckans) meny</a>"
subst = "$1: $2$3: $4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.