re = /<h3 class="lined-header">Dagens meny<\/h3><h4>(.*?)<\/h4><p> ?(.*?)<\/p><h4>(.*?)<\/h4><p> ?(.*?)<\/p><a class="link-button" href="\\\[\[https:\/\/www\.\\\]\(https:\/\/www.fontanhuset.se\/veckan\)website\.com\/weeklymenu">Veckans\]\(https:\/\/www\.\]\(https:\/\/www\.fontanhuset\.se\/veckan\)website\.com\/weeklymenu">Veckans\) meny<\/a>/m
str = '<h3 class="lined-header">Dagens meny</h3><h4>Lunch</h4><p> Rotmos elr potatismos med korv</p><h4>Veg</h4><p> Rotmos elr potatismos med vegkorv</p><a class="link-button" href="\\[[https://www.\\](https://www.fontanhuset.se/veckan)website.com/weeklymenu">Veckans](https://www.](https://www.fontanhuset.se/veckan)website.com/weeklymenu">Veckans) meny</a>'
subst = '$1: $2$3: $4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result