// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<h3 class="lined-header">Dagens meny<\/h3><h4>(.*?)<\/h4><p> ?(.*?)<\/p><h4>(.*?)<\/h4><p> ?(.*?)<\/p><a class="link-button" href="\\\[\[https:\/\/www\.\\\]\(https:\/\/www.fontanhuset.se\/veckan\)website\.com\/weeklymenu">Veckans\]\(https:\/\/www\.\]\(https:\/\/www\.fontanhuset\.se\/veckan\)website\.com\/weeklymenu">Veckans\) meny<\/a>"#).unwrap();
let string = "<h3 class=\"lined-header\">Dagens meny</h3><h4>Lunch</h4><p> Rotmos elr potatismos med korv</p><h4>Veg</h4><p> Rotmos elr potatismos med vegkorv</p><a class=\"link-button\" href=\"\\[[https://www.\\](https://www.fontanhuset.se/veckan)website.com/weeklymenu\">Veckans](https://www.](https://www.fontanhuset.se/veckan)website.com/weeklymenu\">Veckans) meny</a>";
let substitution = "$1: $2$3: $4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}