#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?www(?:-staging)?\.example\.com\/"
Local $sString = "http://www.example.com/" & @CRLF & _
"http://www-staging.example.com/" & @CRLF & _
"https://www.example.com/" & @CRLF & _
"https://www-staging.example.com/" & @CRLF & _
"ftp://www-staging.example.com/" & @CRLF & _
"http://example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")