import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?www(?:-staging)?\\.example\\.com\\/";
final String string = "http://www.example.com/\n"
+ "http://www-staging.example.com/\n"
+ "https://www.example.com/\n"
+ "https://www-staging.example.com/\n"
+ "ftp://www-staging.example.com/\n"
+ "http://example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}