const regex = /^(?:https?:\/\/)?www(?:-staging)?\.example\.com\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?www(?:-staging)?\\.example\\.com\\\/', 'gm')
const str = `http://www.example.com/
http://www-staging.example.com/
https://www.example.com/
https://www-staging.example.com/
ftp://www-staging.example.com/
http://example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}