// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?:\/\/)?www(?:-staging)?\.example\.com\/").unwrap();
let string = "http://www.example.com/
http://www-staging.example.com/
https://www.example.com/
https://www-staging.example.com/
ftp://www-staging.example.com/
http://example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}