using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?www(?:-staging)?\.example\.com\/";
string input = @"http://www.example.com/
http://www-staging.example.com/
https://www.example.com/
https://www-staging.example.com/
ftp://www-staging.example.com/
http://example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}