re = /^(?:https?:\/\/)?www(?:-staging)?\.example\.com\//m
str = 'http://www.example.com/
http://www-staging.example.com/
https://www.example.com/
https://www-staging.example.com/
ftp://www-staging.example.com/
http://example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end