# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^(\d+)\s+\d+/$1/gm;t' <<< "1 4 23 44 52 62
2 3 5 5 5
5 2 3 4"