use strict;
my $str = '1 4 23 44 52 62
2 3 5 5 5
5 2 3 4';
my $regex = qr/(?m)^(\d+)\s+\d+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";