#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)href="https?:\/\/youtu.be\/(.*?)""
Local $sString = "<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>" & @CRLF & _
"<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>" & @CRLF & _
"<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")