import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"https?:\\/\\/youtu.be\\/(.*?)\"";
final String string = "<a href=\"https://youtu.be/z7Pq2N1aFM8\">Le loup et les trois soeurs</a>\n"
+ "<a href=\"https://youtu.be/z7Pq2N1aFM8\">Le loup et les trois soeurs</a>\n"
+ "<a href=\"https://youtu.be/z7Pq2N1aFM8\">Le loup et les trois soeurs</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}