using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""https?:\/\/youtu.be\/(.*?)""";
string input = @"<a href=""https://youtu.be/z7Pq2N1aFM8"">Le loup et les trois soeurs</a>
<a href=""https://youtu.be/z7Pq2N1aFM8"">Le loup et les trois soeurs</a>
<a href=""https://youtu.be/z7Pq2N1aFM8"">Le loup et les trois soeurs</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}