const regex = /href="https?:\/\/youtu.be\/(.*?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="https?:\\\/\\\/youtu.be\\\/(.*?)"', 'gm')
const str = `<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>
<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>
<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}