re = /href="https?:\/\/youtu.be\/(.*?)"/m
str = '<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>
<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>
<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end