# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:calc\(|(?!^)\G)[^)+-]*\K[-+]/ $0 /g;t' <<< "-webkit-calc(50%+4px/2+32px-32px*23%)"