import Foundation
let pattern = #"(?:calc\(|(?!^)\G)[^)+-]*\K[-+]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"-webkit-calc(50%+4px/2+32px-32px*23%)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $0 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)