re = /(?:calc\(|(?!^)\G)[^)+-]*\K[-+]/
str = '-webkit-calc(50%+4px/2+32px-32px*23%)'
subst = ' $0 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result