#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:calc\(|(?!^)\G)[^)+-]*\K[-+]"
Local $sString = "-webkit-calc(50%+4px/2+32px-32px*23%)"
Local $sSubst = " $0 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)