use strict;
my $str = '-webkit-calc(50%+4px/2+32px-32px*23%)';
my $regex = qr/(?:calc\(|(?!^)\G)[^)+-]*\K[-+]/p;
my $subst = ' $0 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";