using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s\_|^\_)([^\_]*)\_";
string input = @"https://slack.global.ssl.fastly.net/12b5a/plugins/slash_commands/assets/service_48.png
Hello _on no_ _oh no_";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}