$re = '/(?:\s\_|^\_)([^\_]*)\_/';
$str = 'https://slack.global.ssl.fastly.net/12b5a/plugins/slash_commands/assets/service_48.png
Hello _on no_ _oh no_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);