import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s\\_|^\\_)([^\\_]*)\\_";
final String string = "https://slack.global.ssl.fastly.net/12b5a/plugins/slash_commands/assets/service_48.png\n\n"
+ "Hello _on no_ _oh no_";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}