re = /(?:\s\_|^\_)([^\_]*)\_/
str = 'https://slack.global.ssl.fastly.net/12b5a/plugins/slash_commands/assets/service_48.png
Hello _on no_ _oh no_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end