const regex = /(?:\s\_|^\_)([^\_]*)\_/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s\\_|^\\_)([^\\_]*)\\_', 'g')
const str = `https://slack.global.ssl.fastly.net/12b5a/plugins/slash_commands/assets/service_48.png
Hello _on no_ _oh no_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}