package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s\_|^\_)([^\_]*)\_`)
var str = `https://slack.global.ssl.fastly.net/12b5a/plugins/slash_commands/assets/service_48.png
Hello _on no_ _oh no_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}