#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<video[^>].*src=\")(?<src>[^"].*)(?=\?)"
Local $sString = "<video id="video" class="playerVideo" autoplay="1" oncontextmenu="return false;" x-webkit-airplay="allow" src="http://vid.pluralsight.com/expiretime=1426057457/9207dc050972394adfa1b36a10c7fcc4/clip-videos/jon-flanders/ios-dotnet-developers-m01-intro/ios-dotnet-developers-m01-intro-01/1024x768mp4/20130301234848.mp4?_=1" type="video/mp4">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")