use strict;
my $str = '<video id="video" class="playerVideo" autoplay="1" oncontextmenu="return false;" x-webkit-airplay="allow" src="http://vid.pluralsight.com/expiretime=1426057457/9207dc050972394adfa1b36a10c7fcc4/clip-videos/jon-flanders/ios-dotnet-developers-m01-intro/ios-dotnet-developers-m01-intro-01/1024x768mp4/20130301234848.mp4?_=1" type="video/mp4">';
my $regex = qr/(?:<video[^>].*src=\")(?<src>[^"].*)(?=\?)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}