const regex = /(?:<video[^>].*src=\")(?<src>[^"].*)(?=\?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<video[^>].*src=\\")(?<src>[^"].*)(?=\\?)', '')
const str = `<video id="video" class="playerVideo" autoplay="1" oncontextmenu="return false;" x-webkit-airplay="allow" src="http://vid.pluralsight.com/expiretime=1426057457/9207dc050972394adfa1b36a10c7fcc4/clip-videos/jon-flanders/ios-dotnet-developers-m01-intro/ios-dotnet-developers-m01-intro-01/1024x768mp4/20130301234848.mp4?_=1" type="video/mp4">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}