using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<video[^>].*src=\"")(?<src>[^""].*)(?=\?)";
string input = @"<video id=""video"" class=""playerVideo"" autoplay=""1"" oncontextmenu=""return false;"" x-webkit-airplay=""allow"" src=""http://vid.pluralsight.com/expiretime=1426057457/9207dc050972394adfa1b36a10c7fcc4/clip-videos/jon-flanders/ios-dotnet-developers-m01-intro/ios-dotnet-developers-m01-intro-01/1024x768mp4/20130301234848.mp4?_=1"" type=""video/mp4"">";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}