# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<video[^>].*src=\")(?<src>[^\"].*)(?=\?)"
test_str = "<video id=\"video\" class=\"playerVideo\" autoplay=\"1\" oncontextmenu=\"return false;\" x-webkit-airplay=\"allow\" src=\"http://vid.pluralsight.com/expiretime=1426057457/9207dc050972394adfa1b36a10c7fcc4/clip-videos/jon-flanders/ios-dotnet-developers-m01-intro/ios-dotnet-developers-m01-intro-01/1024x768mp4/20130301234848.mp4?_=1\" type=\"video/mp4\">"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.