import Foundation
let pattern = #"(?:<video[^>].*src=\")(?<src>[^"].*)(?=\?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<video id="video" class="playerVideo" autoplay="1" oncontextmenu="return false;" x-webkit-airplay="allow" src="http://vid.pluralsight.com/expiretime=1426057457/9207dc050972394adfa1b36a10c7fcc4/clip-videos/jon-flanders/ios-dotnet-developers-m01-intro/ios-dotnet-developers-m01-intro-01/1024x768mp4/20130301234848.mp4?_=1" type="video/mp4">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}