# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Time[^\n]*\n((?:(?!Time|aaa)[^\n]*(\n|$))*(?=Time|$))|(?<=\n)(?!Time|aaa)[^\n]+\n//gs;t' <<< "Time 00:00:01
kkk
lll
aaa
...
Time 00:00:03
kkk
kkk
kkk
lll
lll
aaa
aaa
...
Time 00:00:04
kkk
lll
...
Time 00:00:04
kkk
lll
..."