const regex = /Time[^\n]*\n((?:(?!Time|aaa)[^\n]*(\n|$))*(?=Time|$))|(?<=\n)(?!Time|aaa)[^\n]+\n/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Time[^\\n]*\\n((?:(?!Time|aaa)[^\\n]*(\\n|$))*(?=Time|$))|(?<=\\n)(?!Time|aaa)[^\\n]+\\n', 'gs')
const str = `Time 00:00:01
kkk
lll
aaa
...
Time 00:00:03
kkk
kkk
kkk
lll
lll
aaa
aaa
...
Time 00:00:04
kkk
lll
...
Time 00:00:04
kkk
lll
...`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);