using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Time[^\n]*\n((?:(?!Time|aaa)[^\n]*(\n|$))*(?=Time|$))|(?<=\n)(?!Time|aaa)[^\n]+\n";
string substitution = @"";
string input = @"Time 00:00:01
kkk
lll
aaa
...
Time 00:00:03
kkk
kkk
kkk
lll
lll
aaa
aaa
...
Time 00:00:04
kkk
lll
...
Time 00:00:04
kkk
lll
...";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}