#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)Time[^\n]*\n((?:(?!Time|aaa)[^\n]*(\n|$))*(?=Time|$))|(?<=\n)(?!Time|aaa)[^\n]+\n"
Local $sString = "Time 00:00:01" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
"aaa" & @CRLF & _
"..." & @CRLF & _
"Time 00:00:03" & @CRLF & _
"kkk" & @CRLF & _
"kkk" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
"lll" & @CRLF & _
"aaa" & @CRLF & _
"aaa" & @CRLF & _
"..." & @CRLF & _
"Time 00:00:04" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
"..." & @CRLF & _
"Time 00:00:04" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
"..."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)