re = /Time[^\n]*\n((?:(?!Time|aaa)[^\n]*(\n|$))*(?=Time|$))|(?<=\n)(?!Time|aaa)[^\n]+\n/
str = 'Time 00:00:01
kkk
lll
aaa
...
Time 00:00:03
kkk
kkk
kkk
lll
lll
aaa
aaa
...
Time 00:00:04
kkk
lll
...
Time 00:00:04
kkk
lll
...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result