using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+?44)?(\(\d+\))?[\d ]+(#\d+)?";
string input = @"+447222555555
+44 7222 555 555
(0722) 5555555 #2222
01222 555 555
(010) 55555555 #2222
0122 555 5555#222
+44(0)7518 123 456
+44(0)7518123456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}