package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+?44)?(\(\d+\))?[\d ]+(#\d+)?`)
var str = `+447222555555
+44 7222 555 555
(0722) 5555555 #2222
01222 555 555
(010) 55555555 #2222
0122 555 5555#222
+44(0)7518 123 456
+44(0)7518123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}