import Foundation
let pattern = ##"^(\+?44)?(\(\d+\))?[\d ]+(#\d+)?"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
+447222555555
+44 7222 555 555
(0722) 5555555 #2222
01222 555 555
(010) 55555555 #2222
0122 555 5555#222
+44(0)7518 123 456
+44(0)7518123456
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)