// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+?44)?(\(\d+\))?[\d ]+(#\d+)?").unwrap();
let string = "+447222555555
+44 7222 555 555
(0722) 5555555 #2222
01222 555 555
(010) 55555555 #2222
0122 555 5555#222
+44(0)7518 123 456
+44(0)7518123456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}