$re = '/^(\+?44)?(\(\d+\))?[\d ]+(#\d+)?/m';
$str = '+447222555555
+44 7222 555 555
(0722) 5555555 #2222
01222 555 555
(010) 55555555 #2222
0122 555 5555#222
+44(0)7518 123 456
+44(0)7518123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);